Friday 29th November 2019

CDN Network Performance Issues in London data centre

Resolved - This incident has been resolved. Nov 29, 11:28 UTC

Monitoring - A fix has been implemented and we are monitoring the results. Nov 29, 11:17 UTC

Resolved - This incident has been resolved. Nov 29, 08:17 UTC

Identified - The issue has been identified and a fix is being implemented. Nov 29, 04:05 UTC Investigating - We are is investigating issues with network performance in our London data centre.

We are working to understand the full impact and mitigate this problem. More updates to follow shortly Nov 29, 02:02 UTC